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Notebook software training for SMART Board users level 2 learner workbook

Best practices
and tools
How can I design effective and
interactive lesson activities using
Notebook software?
Many tools are available for creating professional looking interactive lesson activities using Notebook'"
collaborative learning software. SMART's education solutions website provides free sample lesson plans
and templates to save you time, and the SMART Exchange provides an online community enabling you to
collaborate with peers using SMART products.
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Best practices and tools

Tips for designing effective lesson activities using Notebook software

1 Include Teachers' notes and lesson notes at
the beginning of every lesson activity
Documenting learning objectives and key lesson
details will help you to focus your lesson activity
during both design and delivery. It also provides
a clear overview of the lesson to others who may
use the file.

2 Use links to improve the flow of a lesson
You can significantly improve the flow and
organization of your lesson by taking advantage
of the linking capabilities in Notebook software.
You can link any object on a Notebook page to a
webpage, an external file, an attached document
or another page in the same file.

Teachers' notes

Subject Type text here

Topic Type text here

TItle Type text here

Grade(s) Type text here

Cross-curricular link(s) Type text here

Prior knowledge Type text here

Intended learning outcome(s) Type text here

3 Attach supporting files to your Notebook software file before class
Taking time during a lesson to navigate to files you want to show can be awkward and distracting.
Your lesson can lose its momentum and students can lose their focus. To avoid this, attach files,
shortcuts to files and Internet links to the Attachments tab of your Notebook file. You can then open
them with a single press. Everyone remains on track, and no time is wasted.

4 Use a consistent layout for lesson pages
Using a consistent layout for Notebook pages helps your students to know where to look for
information and keeps them focused on important content. Notebook software includes several
themes that you can use as templates, or you can create your own incorporating school colors, logos
and other Objects.
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5 Create lessons that are hands-on for learners
The SMART Board ™ interactive whiteboard is
more than a teaching tool, it's a learning tool.
Students can use the interactive whiteboard to
manipulate objects, complete activities, make
notes during brainstorming sessions and deliver
presentations.

6 Use the Internet and extra resources to
encourage inquiry
Store links to relevant websites and additional
resources as attachments in your Notebook file.
When students are particularly interested in a
topic or have a question, these links can serve as
a starting point for inquiry. Consider planning
virtual field trips or having the whole class
compose an e-mail on the SMART Board
interactive whiteboard with a question or idea to
an expert, an author or another class.
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7 Cater to multiple learning styles in each
lesson activity
Notebook software includes several tools that
enable you to cater lessons to a variety of
learning styles. Auditory learners will
appreciate the sound capabilities. Kinesthetic
learners will benefit from manipulating
Adobe® Flash® activities. Visual learners will
benefit from the rich Gallery collection
included with Notebook software and
processes recorded using the Page Recorder
or SMART Recorder.

aound to play:

I_N_a_m_eo_f_F_ile_I -'1 [~rowse,,, 1

Play

Launch by clicking: o~orner icon 0Qbject

[ Remove Sound 1 [ 00 [C£ncel 1 [ tielp

8 Record processes, instructions or examples to provide further instruction when needed
Notebook software includes a Page Recorder that enables you to record all actions on a Notebook
page. Consider recording a process or example to be played during class if students need additional
clarification on a concept.

Notebook software lesson activities

Take advantace of thousands of Notebook software lesson actMtJes for your dassroom.

Find Notebook software lesson adMtles by:

, Canada
• BrQ\"ISmg cumculum standards
I S.,b'ect and grade Ie:iel
• View all

) Unned States
) BrowsIng cumculum standards

) SUbtect and grade Ieve!
''ilm..lI!1

9 Seek lesson activities on the Internet
Begin by searching through SMART's
education solutions website, which offers
hundreds of ready-made lesson activities, or
use a search engine to find other sources of
lesson activities. Bookmark your favorite sites
to save time searching in the future, and
modify any of the lesson activities to suit your
own needs.

10 Collaborate and share resources with
others
Keep in regular contact with other educators
who are using a SMART Board interactive
whiteboard. Share experiences, ideas,
challenges, lesson activities and solutions.
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Best practices and tools

Notes and ideas for designing effective lesson activities

Use this page to write notes and ideas from the training session discussions.

TEACHER TIP: REVEAL ACTIVITIES

One of the quickest ways to add interactivity to a lesson is with a reveal activity, where the answer to a
question is hidden on the Notebook page. A great way to do this is using erase and reveal.

Type your question and answer, and then use a pen tool to cover the answer with digital ink. Select the
digital ink, and set it to the same color as the page background. For example, if the page background is
white, then the digital ink should also be white. To reveal the answer during your lesson, select the Eraser
tool, and erase the digital ink covering the answer.
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SMART's education solutions website
SMART's education solutions website, found at www.education.smarttech.com. provides numerous
resources for educators, including the following:

• Free learning resources for use with SMART products, including content collections, software
applications and website resources

• Hundreds of Notebook software lesson activities correlated to state and provincial curriculum
standards

• Professional development programs to reward, recognize and support educators

• Research on the effectiveness of SMART Board interactive whiteboards in learning environments

• Advice for educators about using SMART products, integrating peripherals, mastering grant writing and
evaluating technology

oeth America International Site MaD Contad '--- ---'1 [ Search

Technologies

..... .....•• • I'
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Best practices and tools

Lesson activities for Notebook software
To save you time and help generate ideas for your own lesson activities, SMART's education solutions
website provides an easy-to-use tool for finding and downloading free lesson activities in Notebook
software. Many of these lesson activities are created by SMART Technologies. They are identified by the
inclusion of SMART-created in the title. Other lesson activities have been submitted by educators who are
using a SMART Board interactive whiteboard in their classrooms.

Finding lesson activities
You can search for lessons by grade and subject, or find lesson activities that are correlated to your state
or province's curriculum standards.

1 Open your Web browser and go to www.education.smarttech.com

2 Select the Educator resources link

3 Select the Lesson activities link
4 Select the Notebook software lesson activities link

5 Select the Find curriculum standards link or the Subject and grade level link

6 Select your search criteria from the drop-down menus
7 Press Search

Grade
~~~~~BI~~ Use the drop-down

I Please select a grade .., I•••===============::=:=:- arrows to set your

I ~I search criteria.
Please select a subject v •....

Standards

Subject

[ Search I
The search criteria for the Find curriculum standards link. If searching by subject and
grade level only, the Standards option will not be available.

Searching by subject and grade level
If you are searching by subject and grade level, a list of relevant lesson activities will appear in your browser
window.

ISearch Results------------------------------------------~----I. it' Adjectives - Noun Riddles I VieW standards
Select a Imk ./ By using their knowledge of adjectives, nouns, synonyms and rhyming words, students w~1develop
to go to the /" riddles with answers.

download page .">............~ Adjectives, Comparative and Superlative I View Standards

students understand the terms superlative and comparative, identify comparative and superlative
adjectives, and create sentences using superlative and comparative adjectives.

Showing Results 1 to 25 of 82 Next - >
bad: to Conelate 1e:i300 activities

Correlation search results

Click the title of the lesson you would like to use. This action will launch the lesson activity download page.
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Searching by curriculum standards
If you selected the Find curriculum standards link, a list of curriculum standards will appear in your browser
window. To find lesson activities, click the Find correlated lesson activity link within the curriculum
standard you are interested in. If the Find correlated lesson activity link does not appear, no lesson activities
correlated to that specific standard are available at this time.

Standards search results
Alberta - language Arts Grade 2

bsdc to Fi d curriculum sts dards

GENERAL OUTCOME I COURSE AB.1. Students will listen, speak, read, write, view and represent to
___________ explore ~hts, ideas feelil195 and ex riences.

Discover and Explore.GE ERAL OUTCOMEI 1.1.
SPECifIC OUTCOME

SPECIFIC 1.1.1.
OUTCOMEI
illUSTRATIVE
EXAMPLE

SPECIFIC 1.1.2.
OUTCOMEI
illUSTRATIVE
EXAMPLE

Express ideas and develop understanding: Contribute relevant
ideas and information from personal experiences to group
language activities.
(Lesson Activity correlated to this standard)

Express ideas and develop understanding: Talk about how new
ideas and information have changed previous understanding.
(Lesson Activity correlated to this standard)

Click the link for a list of Notebook software lesson activities.

After you click the Find correlated lesson activity link, a list of correlated lesson activities will appear in your
browser window. Select the title of the lesson you would like to use. This action will launch the lesson activity
download page.

Downloading a lesson activity
Once you have selected the lesson activity you would like to download, the lesson activity download page
will load in your Web browser. Select the Download NOTEBOOK link, and follow the instructions.

Adventures with Adverbs

Students identify, sort and dassify adverbs,
and compare and contrast adjectives and
ad erbs in a lesson.

Select to open
or save this
file to your

computer. Download this lesson activity.

~ Nersion 8.1.1, or hiQher, 2103 KB)
Select to see I

a list of

re'a,ted ~ View standards correlated to this resource
cumcuum
standards.

Lori Reed
Canada
Elementsry
K·3
La g us~e arts

Author:
Cou try:

I Level:
Gee e:

Is ie::t:

An adverb is a word that tells
how,
when, or
where about a verb.

View larger image
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The SMART Exchange
The SMART Exchange, found at www.exchange.smarttech.com. is a free resource center and community
network dedicated to technology-enabled learning.

~
Techrloiogies SMART Exchange

Home Forum Calendar Photos Downloads Help

The SMART Exchange features a forum where you can can meet colleagues, share ideas and get answers
from SMART experts, and it also has a calendar of events, photographs and documents that you can
download.

Anyone can read postings
on the forum, however, in
order to contribute, you
need to register. To
register, follow the Join link
found near the top of the
SMART Exchange. You
can then sign in to have full
access to the forum.

Lesson Activity ...
Welcome andannouncements by CoraheO

Newto the SMART Exchange? Find out about updates 04~18.2008 4:11
and leam howto use the Exchange. PM

24 52 -
Help and welcome center

I Forums Last Post Threads Posts

~
Check this thre~d for SMART·sponsored events,
including training sessions, teacher conferences,
trade shoY6 and more.

EduComm 2008

by LiseM

04-17-20086:01
PM

47 120

Conversations, also known
as threads, are sorted into categories - Help and welcome center, Software and content, Programs and
Support, and each of these categories is further subdivided. To see the threads in a category, or to open a
specific thread, click the title.

To respond to a posting, click the I REPLY I button and type your response in the message box that appears.
When you have finished composing your message, click the Preview tab to see what your post will look like
or click I POST I to post your response.

To create a new thread, click the '-\-'I-R-n-E-A-N-E-\-'1-P-O-S-T-lbuttonat the upper-left corner of the forum page.
Then enter the subject and content of your post. Once you are finished, click the Preview tab to see what
your post will look like or click Post. For further details on how to use the SMART Exchange and to learn
about additional features, including the Calendar, searching the Forum, and sending private messages,
click the Help tab.

TIPS FOR USING THE FORUM:

• Search the SMART EXChange before posting. You may find that your topic or question has already
been discussed.

• When asking a question, be precise and proofread it before posting. This extra step will help people
understand your question better so they can provide a prompt reply.

• When posting, make sure that the subject line describes your topic or problem. Experts in your subject
may skim past subject lines like Urgent and Need help ASAP. Use keywords that mention the product
or issue instead.
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Review: Best practices and tools

1 List three tips for designing effective lesson activities in Notebook software.

2 From which website can you download SMART-created lesson activities?

3 What are two resources available on the SMART Exchange?

9



Best practices and tools

Review: Best practices and tools

1 List three tips for designing effective lesson activities in Notebook software.

• Include Teachers' notes and lesson notes at the beginning of every lesson activity

• Use links to improve the flow of a lesson

• Attach supporting files to your Notebook software file before class

• Use a consistent layout for lesson pages

• Create lessons that are hands-on for learners

• Use the Internet and extra resources to encourage inquiry

• Cater to multiple learning styles in each lesson activity

• Record processes, instructions or examples to provide further instruction when
needed

• Seek lesson activities on the Internet

• Collaborate and share resources with others

2 From which website can you download SMART-created lesson activities?

www.education.smarttech.com

3 What are two resources available on the SMART Exchange?

• Forum

• Calendar

• Photographs

• Video and document downloads

10
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Structuring and
organizing lessons
How can I make my Notebook files
organized and easy to use?
The Page Grouping feature in Notebook software enables you to organize pages. Links, buttons and
attachments can help you improve the flow of a lesson activity. Additional features, such as My Content and
team content, help you keep your learning objects and Notebook files well organized.

11



Structuring and organizing lessons

The Lesson Activity Toolkit
The Lesson Activity Toolkit is a newly introduced Gallery collection. It provides many tools and resources
that can be helpful when preparing and delivering a lesson.

You have the option of installing the Lesson Activity Toolkit when installing Notebook software 10. However,
if you did not install it at that time, you can download the Lesson Activity Toolkit from SMART's education
solutions website. To download and install the toolkit, complete the following steps:

1 Open your browser and go to www.education.smarttech.com/slat

2 Click the Download SMART Lesson Activity Toolkit link
3 If prompted to open or save, select Open
4 Click Lesson Activity Toolkit
5 Click Next
6 Click Finish
7 Open Notebook software

8 Click the Gallery tab
9 The Lesson Activity Toolkit will be listed in the Gallery as Lesson Activity Toolkit 1.0

You have access
to six new

collections after ---!!-+
installing Lesson

Activity Toolkit on
your computer.

. iLesson Activity Toolkifi-.o
$ Activities
l±J.. Games

ffi· Graphics
Help
Pages
Tools

Gallery Sampler

< Jill
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Teachers' notes and lesson notes
Just as you would ask your students to include a title page on a book report, lab report or research project
so that you know which student and class it's for, it's a good idea to include key details at the beginning of
any Notebook software lesson activity you create or use. Documenting the subject, topic, grade level and
learning outcomes at the beginning of your Notebook file will help you to focus your efforts on these ideas
as you develop the lesson and easily find appropriate lesson activities when reusing your files in future
years. It will also make it easier for others to get an overview of the lesson if you share your resources.

"'-"~--"I

. B~ck ": I
",oJ ••••~ ••,..·••..••• '

Teachers' notes '" ~..--~.•..•
leiilOfl I1CItt'S

""'1: •••• "!'"~ .-_ .•

Subject Type text here

TOpiC Type text here

Title Type text here

Grade(s) Type text here

Cross-curricular link(s) Type text here

Prior knowledge Type text here

Intended learning outcome(s) Type text here

This is a SMART -created template for Teachers' notes. To use the template, select the text and overwrite the current text with your
lesson activity information.

Lesson notes The templates found in the Lesson Activity Toolkit contain an additional page -lesson notes.
This page is for recording lesson instructions, additional resources or improvements you would like to make
to the lesson activity in the future.

Multipage teachers' notes and lesson notes templates are available from the Lesson Activity Toolkit Gallery
collection, or you can create your own template

13



Structuring and organizing lessons

Title pages and lesson pages
Ready-made pages make it easier for you to add structure and style to your lessons. You can find templates
for title pages and lesson pages - complete with title bars - in the Pages folder of the Lesson Activity Toolkit.

To add one of these templates to your lesson, drag and drop it onto any page of the Notebook file, then fill
out the pages to suit your lesson activity. To change the text on the pages and title bars, highlight the existing
text and start typing .

..• • -~~~"''''''-<> •.

Teachers' notes.
• "'fI~-"'-"'.

~'''''''''~f;

: Lesson notes:-'~--~~ .•. Title page
Insert the topic and learning objectives
to provide an overview of the lesson
activity .Cinquain Poems

• Define cinquain poems
• Review 3 types of cinquain poems

.. -•..~~~
Evaluation '- ... ......,."...,--~-.

Press this button to record your comments and
observations about the lesson activity.

Teachers' notes
Use this page to detail information
about the lesson such as topic or
title. This action will be useful when
you are sharing or revising the
lesson activity.

14

These buttons provide easy
links between the pages.

Teachers' notes
Subject Language arts

Topic Literature

Title Cinquain Poems

Grade(s) 2, 3, 4, 5, 6 and 7

Cross-curricular link(s) Poetry

Prior knowledge

Intended learning outcomes Introduce and define
cinquain poem forms
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Lesson notes

This straightforward lesson activity is designed for
use as a main lesson activity. You can go through
the examples as a class and then ask your
students to complete tasks using their exercise
books.

Modify the examples as needed to suit the needs of
the class.

"---~'1:r{-1f!'I'

Teachers' notes1... ____._..---.1.

Lesson notes
Use this page to document
comments and instructions for the
lesson. You can also use this page
during a lesson to keep track of
student questions or improvements
you would like to make to the lesson
activity.

15



Structuring and organizing lessons

Page grouping
To keep your Notebook files well organized, you can sort pages into groups. This is particularly useful when
there are a large number of pages within a file. Page grouping enables you to view your pages in an
organized way. You can choose to show or hide specific groups, reducing the number of pages visible at a
time. You can also rearrange the order of groups, quickly navigate to a particular group within the Page
Sorter and apply a theme to all the pages within a group.

As a default, each Notebook file has only one group. You can add and modify groups at any time. To view
and edit groups, complete the following steps:

1 Open the Page Sorter tab
2 Press the Groups button

3 Select Edit Groups. If you have not yet edited the groups in the Notebook file, all pages will be in the
default group - Group 1. If you have already edited the groups for this file, the pages are displayed
under the appropriate title bars. .

Press the
Group

Welcome Sign-in sheet Trainer Intro... Agenda
Each group drop-down
is identified ~ menu to

with a title '-- .•.•••:~~-rename,

bar. move or
delete a
group.

Press to
close the
Groups
view.

~;:::et~ --fAdd New Group JHint: Edit your groups by using drag and ...
new group.

_ Introductory Pages

sie 27-14:50 sie 28-12:01 Oct 21-9:10 ...
Press the - r::--.,--..,.------------------------....---.

collapse _ Conclusion
button to ---.
hide the

pages in a
group.

Notebook Le...

To create a new group, complete the following steps:

1 Press the Add New Group button. A new group title bar appears and a new blank page appears
below it. Every group must include at least one page.

2 Press the group drop-down arrow and select Rename Group
3 Type a new name for the group
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Pages and groups can easily be organized
using the drag and drop method. To move
a page to a different group or a different
location in the same group, simply drag the
thumbnail image for the Notebook page to
the new desired location. To rearrange the
order of groups, drag a group's title bar to
the new location. Alternatively, press the
group drop-down menu and select Move
Up or Move Down.

To delete a group, select Delete Group
from the drop-down menu. When you
delete a group, you also delete all pages
within that group, so be sure to move any
pages you would like to keep into a different
group first. If you move all pages out of a
group, the group disappears automatically.

Notebook software training for SMART Board users level 2 learner workbook

•

A4 AS A6

To move a page to a different location, within the same group or in a different
group, simply drag it to the desired location. You can also change the order
of groups using this method.

To close the Groups view, press the Close button in the upper-right corner, or double-click on any thumbnail
image to navigate directly to that Notebook page.

When using the Page Sorter, you can navigate between
groups easily without opening the Groups view. To do
this, press the Groups button at the top of the Page
Sorter, and select the group you would like to see from
the drop-down list that appears.

Groups

Teachers' notes

Questions

Answers

Select theA Conclusion
group you Edit Groups

would like to ---....:..-.------i===;
see from the .l'nswers

drop-down list.

I· -J
A1

-J
The selected
group, in this

case, the --~r-~~5=l
Answers it ~ ~

group, will T;

appear in the
Page Sorter.

A2
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Structuring and organizing lessons

Linking
You can significantly improve the flow and organization of your lesson by taking advantage of the linking
capabilities in Notebook software. You can link any object on a Notebook page to a webpage, an external
file, an attached item or another page in the same Notebook file.

The ability to link to another page within the Notebook file enables you to move between pages quickly,
without using the Page Sorter. Since any object can be linked, you can create objects that serve as
navigation buttons or set different messages to appear based on which object you or a student touches on
the Notebook page.

Many teachers like to write congratulatory messages or hints on specific pages, providing students with
immediate feedback when they touch an object linked to that page. Navigation buttons created with links
found on the message pages allow students to return to the activity easily to try again or move on to the next
activity.

Lightning
~

To respond to the question, the student presses the object that he believes
causes acid rain. All three objects are linked to answer pages within the
Notebook file. After pressing an object, the student will be presented with
one of the two pages shown below.

This causes acid
rain.

This does not cause
acid rain.®

To return to the question page, the student can press the button in the bottom
corner of the page, which is a link back to the question page.

18
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Tips for keeping your linked file organized
To keep your Notebook file well organized, create the required Notebook pages before creating the links.
Place all answer pages at the back of the Notebook file, and separate them from the lesson activity with a
title page. The title page will prevent you from inadvertently displaying the answer pages to your students.

Groups I
Name each page with a unique, short and descriptive name
to make the pages easy to identify when you are creating the
links.

•...)
'2

DTo rename a page, select Rename Page from the page
drop-down menu in the Page Sorter. Type the page name in
the text box that appears.

Vl'hat is .Acid Rain?

•••
Delete Page Del

Clear Page Ctrl+L
c Insert Blank Page Ctrl+M

Acid explana
Clone Page Ctrl+D

Rename Page

~===-
Screen Shade

Show All Links Alt+L

Sentence acti
Add Page to Gallery
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Structuring and organizing lessons

Creating links

To link an object to another page within
the same Notebook file, select Link
from the object's drop-down menu, and
select Page in this File from the Insert
Link dialog box.

A list of the pages in the current
Notebook file will appear. Select the
page you would like to link to. The Page
Preview pane enables you to confirm
your selection before creating the link.

Select whether you would like to launch
the link by clicking Corner icon or
Object.

Press OK to create the link.

Car

Clone

Cut

Copy

Paste

Delete

Ctrl+D

ctrl+X

Ctrl+c

Ctrl+V

Del

Check Spelling ...

Locking

Grouping

Flip

Order

Infinite Cloner

Link...

Sound •••

Properties ...

Page Preview:r-----~-----------,
Web Page

Page in this File

File on this Computer

Current Attachments

Select a page:

G- Page Titles
., 1: Title Page
,.. 2: What is Acid Rain?

3: Causes
4: Acid explanation
5: Sentence activity

, 6: Answers title page
'... 7: Answer What is Acic
:....8: Answer No
L...@i,HiNirM

.. 10: Answer Minor effe
11: Answer Sentence .

....·12: Sep 15-5:46 PM

<I

Launch by clicking: 0Corner icon 0Object

[ Remove Link 1

This causes acid
rain.

OK J [ Cancel 1 [ Help

v

In this example, pressing anywhere on the object will /ink to the page Answer Yes, indicating
that the object does contribute to acid rain. Brief but descriptive page names make it easy to
select the correct Notebook page for the link, and the Page Preview pane confirms the selection.
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Show All Links
If you are working with a Notebook file that contains many links that you
have not recently used or that someone else created, you can use the
Show All Links feature to be sure that you have not overlooked any
links that are hidden by surrounding Objects.

Show All Links briefly highlights all objects on a Notebook page that are
linked to a website, file, another Notebook page or a sound with an
animated box. Select View> Show All Links to identify the links on
the current page once, or select View> Show All Links When Page
Opens to highlight the links each time you open the page during the
current session.

Car

Lightning

Insert Format Draw Senteo Help

Page Sorter Alt+1

Gallery Alt+2

• Attachments Alt+3

Properties Alt+4

Next Page PgDn

Previous Page PgUp

Screen Capture Toolbar

Screen Shade

>I Auto-Hide Side Bar

Customize Toolbar ...

Full Screen Alt+Enter

Zoom

" lOW All Links

Show All Links When Page Opens

Language Setup ...

An animated box appears
to highlight each link on
the page.
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Structuring and organizing lessons

Attachments
Taking time during a class to navigate to the files you want to show can be awkward and distracting. Your
lesson can lose its momentum and students can lose their focus. To avoid this situation, attach files,
shortcuts to files and Internet links to the Attachments tab of your Notebook file and open them easily during
your lesson. You can then open them with a single press. Everyone remains on track, and no time is wasted.
Attachments give you ready access to the information you want to display.

Attaching a copy of a file
You can add a copy of a file to the Attachments tab. This step
enables you to keep all resources for a lesson in one place,
making organizing your electronic files much easier.
However, when you attach a file, the size of the Notebook file
increases.

file !\lame

Sample Laws, pdf

Government, notebookTo add a copy of a file to the Attachments tab, do the
following:

1 Press the Insert button on the Attachments tab

2 Select Insert Copy of File
3 Navigate to and select the file you would like to add and

press the Open button
When you open the file from the Attachments tab, it will be in
Read-only format. If you would like to save changes to a file
stored in the Attachments tab, use Save As.

Attaching a hyperlink
To save time finding Internet resources and reduce
distractions during your lesson, you can add hyperlinks to the
Attachments tab, similar to saving bookmarks or favorites in
your Web browser.

[ Insert. .. 1

oAuto-hide
Attach supporting lesson files to a Notebook file to
save time and improve lesson flow.

To add a hyperlink to the Attachments tab, do the following:

1 Press the Insert button on the Attachments tab

2 Select Insert Hyperlink
3 Type the hyperlink address into the Hyperlink field
4 Type the text you would like to see in the Attachments list - for example, the website name - into the

Display name field
5 Press OK

The hyperlink appears in the Attachments tab. To open the webpage in your default browser, double-press
the link.

Attaching a shortcut to a file
A shortcut is a link to a file that is stored outside of Notebook software. To add the shortcut to a file in the
Attachments tab, do the following:

1 Press the Insert button on the Attachments tab
2 Select Insert Shortcut To File
3 Navigate to and select the file you would like to add and press the Open button
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My Content
You can add your own images, objects and entire Notebook pages to the Gallery, or save your favorite items
into an easy-to-find location using the My Content folder. My Content is a Gallery collection reserved
specifically for objects you have imported, captured or created. If there are any templates or tools that you
use on a regular basis, such as your school logo or a lesson template, you can save time and reduce extra
work by adding them to your My Content folder.

Adding items to My Content
To add an item to the My Content area, drag the item from the
work area, the Page Sorter or the Gallery to the My Content
folder in the Gallery.

To import additional files from your computer, including pictures
you have taken with a digital camera or downloaded from the
Internet, follow these steps:

1 Select the Gallery Actions icon to the right of the search
button

2 Select Add Other Files to My Content to launch the Add
to My Content... dialog box

3 Browse to and select the file you would like to add

4 Press the Open button
5 Your file will appear as a thumbnail in the My Content area

of the Gallery

Organizing My Content
Within the My Content folder, you can create your own folders
and subfolders to organize your Gallery content any way you
like.

To add a subfolder to My Content, do the following:

1 Select the My Content menu arrow or a subfolder menu
arrow

2 Select New Folder. A new folder will appear.

3 Type a name for this folder

!Type search terms here

8 My Content
Grade 7a Science
Grade 7b Science

8-- Grade 8 Science
~~ Fluids
.:.. Magnetism '"

Grade 9 Math
Template items

Adding keywords to objects in the My Content area
The search function in the Gallery works by scanning keywords associated with each Gallery item. When
you add an item to the My Content area of the Gallery, you can provide keywords to the item so it is
recognized by the search function and appears in future search results.

To add keywords to a My Content item, do the following:

IUI

1 Press the item's thumbnail in the My Content area
2 Press the drop-down menu arrow

3 Select Properties to launch the Gal/ery Item Properties dialog box

4 Type the keywords you would like associated with the item. For example, you could type editing and
symbol if the Gallery item is an editing symbol you frequently use

5 Press OK

Magnetism
4 items

A Pictures and Backgrounds (4)

electromagnet
diagram

em wave
diagram

loudspeaker magnetic field

Create subfolders within My Content to organize
learning objects according to grade or class.
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Structuring and organizing lessons

Team content
You can save time and encourage teamwork by sharing lesson activities with other teachers in your school
or district. If you are using the same computer network, you can save your lesson activities, Notebook files,
Gallery Collections, images and multimedia files in a shared team content folder on the network. Multiple
users can connect to the same content location, and changes made by one user are automatically updated
for the other users.

A team content folder can be created by your network administrator, and instructions can be found on
www.smarttech.com. under the Support heading.

To connect to your team content folder, select the Gallery Actions icon to the right of the search button,
then select Connect to Team Content. Follow the prompts to locate your team content folder.

To copy files to a team content folder, select and drag files or objects from the My Content area of the Gallery
to the team content folder. If you want to save your own changes or access the files when you are not
connected to the network, copy the files from the team content folder to your My Content folder.

The Gallery Actions icon.

L....:..:...- El
My Content

Games
Selling • _

Online Essentials for Ed~~~rs
Themes •

Essentials for Educators "
Humanities Team .• .-'
Lesson Activity Toolkit 1,0

I_T,_:,p_e_5_e_ar_c_h_te_r_m_s_hp._~r_e__ -,EJ
I$)· My Content

Games
Spelling

Online Essentials for Educators
Themes
Essentials for Educators
Humanities Team

Spelling

You can select and drag the Spelling folder from the My Content The entire Spelling folder now exists as a subfolder in a team
area into the Humanities Team team content folder. content folder called Humanities Team and is accessible by

others through the network.

Since multiple users can connect to the team
content folder to add, update or delete content,
select Refresh from the drop-down menu to
ensure that you are always seeing the most
up-to-date content.

To disconnect from a team content folder, select
Disconnect from the drop-down menu. You can
skip this step to have the folder appear in the
Gallery window the next time you open Notebook
software.
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Online Essentials for Educators
Themes
Essentials for Educators

New Folder

kit 1,0Copy

Paste

Delete

Disconnect

Refresh F5

Rename

Add to My Content

Refresh content in the team content folder or disconnect from the
network.
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Review: Structuring and organizing lessons

1 List two ways to use links to improve the structure and organization of a lesson activity.

2 How do you turn on the Show All Links When Page Opens setting?

3 How do you move a page from one group to another?

4 What are the three ways you can attach items to a Notebook file?

5 Why would you add a keyword to an item in the My Content folder?

6 What is a team content folder?
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Review: Structuring and organizing lessons

1 List two ways to use links to improve the structure and organization of a lesson activity.

• Link an object to another Notebook page, eliminating the need to use the Page Sorter

• Link an object to a webpage so that it automatically opens the browser to the correct location

• Link an object to an attached file to eliminate the need to open the Attachments tab

2 How do you turn on the Show All Links When Page Opens setting?

Select View> Show All Links When Page Opens to highlight the links each time you open the
page during the current session.

3 How do you move a page from one group to another?

Open the Page Sorter, press the Groups button and select Edit groups. To move a page to a
different group, simply drag the thumbnail image for the Notebook page to the new desired location.

4 What are the three ways you can attach items to a Notebook file?

You can add attachments as files, shortcuts to files and Internet links.

5 Why would you add a keyword to an item in the My Content folder?

You can add keywords to items in the My Content folder so that they can be located using the
Search function in the Gallery.

6 What is a team content folder?

A team content folder is a shared network folder for storing Notebook files, Gallery Collections
and other learning objects that can be accessed through the Gallery by colleagues using the same
network.
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Adding style 0
lesson activities
How ca n I create
profess ion a 1-100 ki n9
lesson activities?
Notebook software 10 includes many new features to enable you to create lesson activities with a
professional look. Themes, alignment tools and tables will enable you to create visually appealing
Notebook files.
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Adding style to lesson activities

Properties tab
The Properties tab provides easy access to formatting and editing options for a selected object or objects
on a Notebook page. Many formatting options are accessible through the Properties tab, however only those
options that are available for the currently selected object will be visible at any time. These options may
include the following items:

• The color, transparency and fill effects of objects

• The color, thickness and style of lines

• The font type, size and style of text

• The animation settings for objects

The Properties tab also includes a Page Recording tool, enabling you to record actions on the current
Notebook page.

Opening the Properties tab
There are three ways to access the Properties tab:

1 Press the Properties tool bar button

2 Press the Properties tab

3 Select the object, press the object drop-down arrow and select Properties

Changing an object's properties
To change an object's properties, select the object(s) and open the Properties tab. You can select several
objects and change their properties at the same time. Any modifications that you make in the Properties tab
will be immediately visible on the selected object(s).r-----------------------~~=-~

Fin Effects

ITimes New Roman

Select a new font from
the drop-down list. The4-~-------'===~change will be
immediately visible in
the selected object.

Each of these four

Line Style tabs contains
~=====~~~~~===~~tt~~~settingS that can be

T ext Style modified for the
currently selected
object.Object Animation

Page Recording

r
: 2 "
i Text
L-------b

Font

Size ---

A text object is selected,
so any object properties
that apply to text are
displayed in the
Properties tab.

B I n
-'

~ 2
X

!

-
Font style

The properties that you are able to modify vary depending on the type of object that is selected.
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Fill effects
In this section, you can change the transparency and fill effects of an object. Increasing an object's
transparency means that the image appears lighter on the page, enabling you to see objects that are placed
behind it. To change the object's transparency, drag the slider from solid to more transparent.

With many objects you can also change the color and type of fill used in the object. There are four available
fill types:

1 Solid fill - Select a color from the color palette to fill the object entirely. To access more color options,
press the More ... link.

2 Gradient fill - This type of fill changes, in a gradual transition, from one color to another. Select a color
from each of the two palettes. Select a style (the direction the fill transitions in) from the drop-down
list. The object will change on a gradient from one to the other.

3 Pattern fill - This type of fill fills your object with the pattern that you select from the palette. You can
also select foreground and background colors for your pattern by clicking the appropriate links. the
palette will adjust using your selected colors, making it easier to choose.

4 Image fill - Select image fill to fill your object with an image file you have stored on your computer.
Press the Browse link to locate your image file. The image file will be imported in its original size. If
you have large files and would like to be able to see the entire image, resize the file using your photo
editing software file before using it as a fill.

Solid fill Gradient fill Pattern fill Image fill

TIP: Whenever you are selecting colors, you have the option of using the eyedropper tool. This tool
enables you to select a color from anywhere on your display and use it as the fill color. To use the
eyedropper, select the object you would like to modify. Then, press the button. Your cursor turns to
an eyedropper. Press once where the color is located that you would like to use. Your object will be filled
with that color.

Line Style
Press the Line Style tab to modify line settings for a line or the outline of an object. Select the color and
thickness from the palettes provided. Next, select the line style, and start and end styles from the drop-down
menus.

Text Style
Press the Text Style tab to modify font properties including the font type, size and style.
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Adding style to lesson activities

Themes
You can use themes to apply a consistent style to pages or groups of pages in a Notebook file. The Gallery
includes predefined themes, and you can also create your own. To apply an existing theme to a Notebook
page or a group of pages, complete the following steps:

1 Open the Gallery tab

2 Select Themes. The Gallery displays thumbnails of the available
themes.

3 Select the thumbnail of the theme you want to apply

4 Press the thumbnail's menu arrow and select Insert in Notebook.
The Insert Theme dialog box appears.

5 Select which pages you would like to apply the theme to

6 Press OK

To create a new theme, complete the following steps:

1 Open the Gallery tab

2 Select Themes

SMART t.eerninu Marketplace
My Content
Online Essentials for Educators
Themes
Essentials for Educators
lesson Activity Toolkit 1,0
Gallery Sampler

ABC. 1 ABC. 2

3 Press the menu arrow and select Create New Theme

4 Type a name for the theme in the Theme name box

5 Select the text object that appears in the workspace, and modify ABC. 3 ABc.4

the text to your desired default text style for the theme. This text
object will not appear in the completed theme.

6 Modify the workspace to reflect your new theme. You may need to scroll down to set up the entire
Notebook page.

7 Press Save
Theme name' ICustom

Theme text style: Verdana and black color?o

Add objects to the workspace as if it were a Notebook page. You can set a default font by modifying
the text object that appears in the workspace. When finished, press the Save button.

To delete a theme, right-click on the workspace and select Delete Theme. You can delete a theme from an
individual page, but you cannot delete the theme from all the pages in a group or a file at the same time.
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Active alignment
When arranging objects on a Notebook page, you may want to align objects to increase clarity of your page.
Notebook software can display guides on the page to assist you in aligning objects with other objects, the
page's vertical center and the page's horizontal center.

To display guidelines, select Format> Alignment. The
Alignment Guides dialog box appears.

There are three types of alignment guides available. Check
the Alignment Guides options you would like to use. To turn
a guide tool off, uncheck it.

Select Show guides for active objects to display a guideline
when you move an object into alignment with another object.
Guides will appear on the page to assist you in aligning
objects to any side or center of a nearby object.

Select Show vertical page center guide to display a guide
when you move an object toward the page's vertical center.

Select Show horizontal page center guide to display a
guide when you move an object toward the page's horizontal
center.

~ ~how guides for active objects

o Show ~ertical page center guide

oShow tlorizontal page center guide

o Snapqbjects to guides

Guide color

OK 1 [ Cancel 1 [ Help

You can customize the active alignment feature by
selecting only those alignment guides you would like to
see when working in Notebook software.

If you would like objects to snap to guidelines as you move the object on the Notebook page, check the
Snap objects to guides option.

To change the guide color, press the Guide color box and choose a new color from the palette.

If you have turned on any of the alignment guides, they will appear when appropriate when you are working
on the Notebook page. As you move an object in range of another object, or the horizontal or vertical center
of the page, the guides will appear. If you selected Snap object to guides, your object will automatically snap
into place on the guideline.

f?t'il
!~1'-------0
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Tables
To add a table, complete the following steps:

1 Press the Table button or select Insert> Table. An eight by eight grid appears.

2 Select the number of columns and rows that you would like to include in the table by dragging over the
cells in the grid

3 The table appears on the Notebook page

Adding text and objects to tables
Once you have created your table, you can add text and objects, including freehand objects, geometric
shapes, straight lines and graphic files to the table cells simply by dragging and dropping. To add text to a
table cell, double-click on a cell. A text box will appear. To add an object to a table, select the object and
drag it to the destination cell. To remove an object from a table, select it and drag it out of the table.

TIP: Each cell can contain only one object. If you would like to add multiple Objects to a cell, for example,
an image and a text descriptor of the image, group the objects before adding them to the table.

Selecting tables, columns, rows or cells on a Notebook page
You can select a table, a column, a row, an individual cell or a selection of cells. After you have selected a
table or a part of a table, you can modify the properties of the selected area.

Selecting a table is easily accomplished using the marquee select method. Use the select tool, and drag a
rectangle to encompass the entire table.

To select cells, rows or columns, press inside the table area and drag over the specific cells you would like
to select.

Moving and resizing tables
Press and drag

this handle to
move the table.

~~ ,
j i, :,

Tool Use !!
i
j !i
! Magic To easily create a !i pen spotlight, magnifier or

I
:

fading object when i
, presenting

1
I Shape To convert free-hand I! pen shapes into proper !

i shapes !

To move a table on the Notebook page or to
another page, select it. A square handle appears
in the table's upper-left corner. Use this handle to
drag the table to the desired location.

To resize a table, select the table and press the
resize handle in the lower-right corner of the table.
Drag the handle to increase or reduce the size of
the table.

··--7
Press and drag
this handle to
resize the
table.
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Resizing columns and rows
You can resize rows and columns by pressing the
table lines and dragging them to adjust them to the
preferred size. For example, to expand the width of
the first column, press the vertical line to the right of
the column. A double-headed arrow appears. Drag
the vertical line to the right to create a wider column.
You can use this method to alter the size of any row or
column, but you are limited by the height and width of
the table. If you would like to increase the height or
width of the table, drag the outer edge of the table to
the desired height or width.

Tool Use

Magic pen To easily create a spotlight, magnifier
or fading object when presenting

..• ..
Shape pen To convert free-hand shapes into

proper shapes

To adjust column width, press on the line and drag it.

Inserting or removing columns, rows or cells
After creating your table, you can customize it by inserting or removing columns, rows and cells. To add a
new column or row, select a column or row, right-click and select Insert Column or Insert Row. New
columns will appear to the right of the selected column. New rows will appear below the selected row.

To remove a column or row, select a column or row, right-click and select Delete Column or Delete Row.
The currently selected row(s) or column(s) will be deleted.

You can also delete an individual cell or group of cells from a table. For example, when creating a crossword
puzzle, you wouldn't want a complete grid to appear. To delete unnecessary cells, select the cell(s) you
would like to delete, right-click and select Remove Cells.

Splitting or merging table cells on a Notebook page
To further customize the appearance of your table, you can split and merge cells. To split a cell means to
turn one cell into two or more cells within the same area. Notebook software provides several options for
splitting cells, including split into 2x2, split into 3 rows and several other options.

"lerg. (e~o;;

Insert Row
pelece ~',OV>i

lnse t rc.llJr,()

SpIt 'I' SpIt into 2 Cok..mns
I_Delet_e(_01,_--; 5pIt"'0 2 Rows

SpIt "'0 2x2
Split no 3 CoUms

Split into 3 Rows

Split i'to 3x3

Add eel Shade

Properties ...

I I

To merge a cell means to turn two or more cells into one cell that then occupies the same area as the
individual cells. To merge cells, select the cells, right-click and select Merge.

33



Adding style to lesson activities

Cell shades
Cell shades are similar to a Screen Shade, but they cover and reveal the
contents of individual cells within a table. Cell shades enable you to reveal
the table content at a pace appropriate to the lesson. You can add a cell
shade to an individual cell, a group of cells such as a row or column, or an
entire table.

To add a shade to a cell, multiple cells or an entire table, select the cell(s).
Right-click and select Add cell shade.To remove a shade from a cell,
multiple cells or an entire table, select the cell(s), right-click and select
Remove cell shade.

To reveal the contents of a cell covered by a cell shade, press once on the
cell shade.
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Lesson pages
Ready-made pages make it easier for you to add structure and style to your lessons, and using consistent
page templates lets the viewer know where to look for information. You can find templates for title pages
and lesson pages - complete with title bars - in the Pages folder of the Lesson Activity Toolkit.

To add one of these templates to your lesson, drag and drop it onto any page of the Notebook file, then fill
out the pages to suit your lesson activity. To change the text on the pages and title bars, highlight the
existing text and start typing.

(7~ Type here to edit title:'" ,

Adobe Flash version of a lesson page template. Press the? to Notebook page version of a lesson page template. Use the pull
add notes and instructions so that they will appear in the title bar tab to add notes and instructions or delete it.
any time the? is pressed.

Lesson pages from the Lesson Activity Toolkit are available in both Adobe Flash and Notebook page
format. The Adobe Flash pages include a Help button. Press this button to add important text to your page
to explain the activity or provide needed information. The version for the Notebook page includes a pull tab
for you to add text to or delete if it is not required.
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Graphics
Icons and images from the Graphics folder will help you create sophisticated and engaging language arts
lessons. Title bars and pull tabs can be dragged directly onto the Notebook page. You can assign page links
and weblinks to buttons and icons to make the lesson more interactive and engaging, and improve the flow.
The Lesson Activity Toolkit provides all items in five colors, enabling you to select a background in your
preferred color, and color coordinate the graphics, icons and buttons.

Icons from the
Lesson Activity
Toolkit

11. ••• -=::Ii. _I
Standard text
messages from the
Lesson Activity
Toolkitn!

-~-~-"'-i

Next~~....,~~.
Buttons from the
Lesson Activity
Toolkit

You can add links to buttons and any other graphic from the Lesson Activity Toolkit to improve the flow of
your lesson. To add a link to an object, complete the following steps:

1 Select the object drop-down menu
2 Select Link
3 Edit the link location details in the Insert Link dialog box

4 Select whether to launch the link by clicking the corner icon or the object

5 Press OK
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Review: Adding style to lesson activities

1 How do you turn active alignment on?

2 How do you move a table?

3 How do you add a cell or table shade?

4 What is a theme?

5 List four items you can modify in the Properties side tab.
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To move a table on the Notebook page or to another page, select it. A square handle appears in the
table's upper-left corner. Use this handle to drag the table to the desired location. ...-.,

Adding style to lesson activities

Review: Adding style to lesson activities

1 How do you turn active alignment on?

Select Format> Alignment. The Alignment Guides dialog box appears. Check the Alignment
Guides options you would like to use and click OK.

2 How do you move a table?

3 How do you add a cell or table shade?

To add cell shades to an entire table, select the table, press the table's menu arrow and select Add
table shade. To add a shade to a cell or multiple cells, select the cell(s), right-click and select Add
cell shade.

4 What is a theme?

A theme is similar to a template. It is a set of predefined style settings you can add to a Notebook
page or group of pages in a Notebook file.

5 List four items you can modify in the Properties side tab.

• The color, transparency and fill effects of objects

• The color, thickness and style of lines

• The font type, size and style of text

• The animation settings for objects

--
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Building interactive
lesson activities
How can I take advantage of the
interactive features in Notebook
software in my lesson activities?
Notebook software includes many tools and features that enable you to make lesson activities that are
engaging and interactive. Bringing students up to the interactive whiteboard provides them with a hands-on
experience that they will remember.

39



Building interactive lesson activities

Dual page display and pin page
In some lesson activities, you may want to display two pages side by side. For example, you may want to
display new vocabulary words on one page and an activity on another page, or you may want to display
steps to solving a particular type of math problem on one page and a math question for your students to
complete on another page. You can display both of these pages at once using Dual Page Display. You can
draw, make notes, import files and add links on either page just as you would on a single page, and even
move objects between the two pages.

To use Dual Page Display, press the Dual Page Display button on the Notebook software toolbar or
select View> Zoom> Dual Page Display. The work area will be split into two panes showing two
consecutive Notebook pages.

Land Water

,. •. .

?J:$ t ~_#
(illiD"''''''''''''''''''''~1- -

Dual Page Display allows two Notebook pages to be displayed at the same time.

To close Dual Page Display, press the Single Page Display button
or select View> Zoom> Single Page Display.

on the Notebook software tool bar

Pin Page
When working in Dual Page Display, the Pin Page feature enables you to lock one page in place while still
using the other pane to navigate through your Notebook pages. For example, when introducing new
vocabulary, you may want to keep a vocabulary list displayed on one page, and display various activities in
the other pane. This approach enables students to refer to the new terminology or drag the vocabulary
words onto the activity pages as needed. --
To pin a page, navigate to the page you want to pin - in this scenario, the vocabulary list - and select View
> Zoom> Pin Page. Thumbtack icons appear in the top corners of the pinned page. When you press the
Next Page button, only one of the two displayed pages - the one without the thumbtack icons - will change.
You can unpin the page by following the same steps.

The pin icons __
H

~ iiII ir._;;;;~;; "~Nr::==============
indicate that
this page is

locked in
place.

40

Wilic:ll fof'ITIS of tr"Cll\$po~t4tion ere .,Iso fcrlllS of exer
Land Water Air

r:

~ ..p
I

When the Notebook pages are turned, the left-hand page will remain on-screen because it has been pinned. It
can be reused, but a new page - and in this case a new activity - will appear in the right pane.
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Gallery content for interactive lessons
There are two ways to find content in the Gallery. The search field at the top of the Gallery tab allows you
to search by keyword - much like using an Internet search engine. Use the Gallery's search function if you
are looking for specific content related to a keyword, such as speech bubble. You can also browse the
Gallery Collections by navigating through the folders and subfolders. Browse through individual folders if
you are looking for all objects related to a general topic, such as tree or handwriting.

The search field
To search for objects in the Gallery
using the search field, follow these
steps:

The EJ 1==:::1 The
search --"I~ILa~d~ve~rb~ J v ••....••I---}"-+--,-..,.,.... .••.search

field. button.
SMART Learning Marketplace
My Content
Online Essentials for Educators
Themes
Essentials for Educators

, Lesson Activity Toolkit 1.0
Gallery Sampler
Search Results for adverb

1 Click or press once inside the
search field

2 Type a keyword related to the
type of object(s) you are looking
for

3 Press the search button to display
your results

Search Results for adverb
13 items

Gallery Collections
A Gallery collection is a group of
Gallery content - images, pages and
multimedia items - that you can add
to Notebook software. SMART has
created a Gallery collection
specifically for educators, including
curriculum-relevant templates and
images for the K-12 school system.
This collection is called Essentials for
Educators.

Related Folders (3)

,. Pictures and Backgrounds (10)

Gallery
search

results for-+---.
the search

term
adverb

el

To add Essentials for Educators to your Gallery in Notebook software, complete the following steps:

1 Click the SMART Board icon in the notification area
2 Select Check for Updates
3 The SMART Product Update wizard appears. This update wizard checks for updates for any SMART

software on your system.
4 Press the Update button next to SMART Essentials for Educators if it is available

5 Follow the on-screen instructions

Within the Essentials for Educators collection, there are several folders containing Gallery content. To
quickly access the relevant content for your subject, follow these steps:

1 Open the Gallery tab

2 Select Essentials for Educators
3 Click the + sign next to a folder to expand the category and view the related subfolders
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The Gallery organizes content into the following four categories: Pictures and Backgrounds, Interactive and
Multimedia, Lesson Activities and Notebook Files and Pages. Thumbnails within the categories provide
preview images of the content and indicate the variety of content. You can easily add your own background
pages, clip art, multimedia and Flash content files to the My Content category.

Pictures and Backgrounds
The Gallery features thumbnails of its contents. Clip art and
photographs appear as thumbnail images. Background pages
are shown as pages with a dog-eared corner. Adobe Flash .swf
files appear as either a Flash icon or a thumbnail of the content
with a small Flash icon in the upper-left corner.

Pictures and Backgrounds (137)

Notebook Files and Pages
When you add a Notebook page, it is inserted on a new page
immediately following the current page. A Notebook file is a
collection of pages. If you add a Notebook file, the pages it contains are inserted after the current Notebook
page.

Adult frog Alligator

Lesson Activities
The Gallery includes several complete Lesson Activities that you can use in your class, modify to suit your
needs or review for ideas on how to use Notebook software. Many more lesson activities are available online
at www.education.smarttech.com.

Interactive and Multimedia Content
Video and Adobe Flash content is easily accessible from the
Gallery. Video content can be used to give students an impression
of a historical event or to demonstrate how something moves,
such as microscopic cells. Flash can be used when you want
students to interact directly with a learning object and receive
instant feedback.

When you are searching for content related to a specific topic,
Flash and video Gallery items are always located under the
Gallery header Interactive and Multimedia.

There are hundreds of Flash and video Gallery items.To browse
through the Interactive and Multimedia content available from the
Gallery, type video or Flash in the Gallery search field, and
experiment with the Gallery items to learn how you can apply them
to your lessons.

~~,
I

IIf!
~

--

Potential pitfalls
Multimedia elements are a popular way to integrate content to your lesson activities that appeal to different
learning styles. These tools are a good supplement to any lesson, but should be used with restraint. Filling
every page with animations, videos and sound can distract students from the learning objectives and direct
their focus to the technology instead of to the lesson content.

lO-sided dice Abacus

Use and experiment with all the tools available to you, but make sure you know why you are using a specific
tool - to meet a learning objective.
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Attaching sound
The sound capabilities for Notebook software are an ideal tool for teaching language skills and will also
appeal to auditory learners. Attaching an audio clip to an image enables students to see a word and hear it
pronounced at the same time. You can also attach longer sound files, including sound effects, songs and
conversations that students can listen to, repeat and discuss.

To attach a sound file to an object, complete the following steps:

1 Select the object that you would like to attach a sound file to

2 Select Sound from the object's drop-down menu. The Insert Sound dialog box appears.

3 Type the name of the sound file to attach to the object, or press Browse to locate and select the
sound file

4 Press the Play button if you would like to preview the sound to ensure it is the right file

5 Select whether you'd like to launch the sound by clicking a corner icon or the object
6 Press OK. The sound file is now associated with the object and the sound file is saved as a part of the

Notebook file.

Insert S~und - --. ..~- . -_. - .- ..- - --- ru~
aound to play:

r

1_' 1 [!!rowse ... )

Play

Launch by clicking: o~orner icon 0Qbject

Cil,ncel I [ tielp! Remove Sound I
Students can press the
sound icon to hear the

word "bear. "

Select whether you would like the sound file to launch when a person presses
the object, in this case - the image of the bear - or by pressing a corner icon.

TEACHER TIP: An interesting way to use sound in a lesson is to place several words, each with a sound
file containing the correct pronunciation of the word attached, on the Notebook page. Students can
rearrange the words to build sentences. After creating the sentence, they can press the words to hear
the sentence and make sure it makes sense and repeat what they hear.

Song is also a fun way to use sound in lesson activities. Attach a verse of a song to a text object
containing the lyrics. Students can listen to the song and follow along by reading or singing the lyrics
displayed on the Notebook page.
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Object Animation
You can add excitement to your lesson activity and emphasis to key points by using Object Animation. You
can animate an object to fly in from the side of the page, spin, fade in, shrink and more, choosing when the
animation takes place, at what speed and for how long. You can add animation to a text object or any object
created with the Shapes tool or any of the pen tools.

To animate an object, complete the following steps:

1 Select the object you would like to animate

2 Open the Properties tab

3 Select the Object Animation tab
4 Using the drop-down lists provided, select the animation

Type, Direction and Speed
5 Select the animation timing from the Occurs drop-down list.

You can set the animation to take place when you enter the
page or when you click the object.

6 Select how many times the animation repeats from the
drop-down list
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Interactive resources from the Lesson Activity Toolkit
The Lesson Activity Toolkit contains several interactive resources that will keep your students involved and
make learning fun.

Category sort Checker tool 1 Hot spots 1
Sentence
arrange

Tiles 2 Suduko Crossword

Games and activities
The table below lists only some of the resources available in the Lesson Activity Toolkit, so be sure to
browse through the folders to find additional activities and games that work for you, and creative ways to
use them. The Examples folders may help you generate some ideas.

Activities Games

Category sort Anagram

Keyword or image match Crossword

Multiple choice Dominos

Sentence arrange Hotspots

Tiles Sudoku

Timeline reveal Word biz

To add an item from the Lesson Activity Toolkit to your lesson, select a thumbnail image and drag and drop
it onto the work area.

Editing a Flash activity or game
Most Flash activity and game templates have an Edit button that enables you to customize the activity or
game, and a Help button that displays detailed instructions for building and using it. Press Edit to get
started. Fill in the blanks and make any selections required to set up the activity or game.

When editing the activities, games and tools, you can add text by typing in the text fields, or by dragging
and dropping text from the Notebook page, word processing software or a webpage or other software
program, into the text fields to speed-up activity creation. For example, if creating a multiple choice activity,
you can drag both the questions and answers from your existing quiz found in a word processing document.

If you would like to ensure that others cannot edit your activity or game, check the Password box, and set
a password. This action can prevent participants from accidentally accessing the edit area of the activity
during class.

To add an image to a game or activity such as the Image match, Hotspots or the Tiles activity, drag the
image onto the work area and send it behind the activity by selecting Order> Send to Back from the object
drop-down menu.
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Press OK to save your edits.

Check this box and type in a
password to protect the activity
or game.

Drag an image
to each image

box, then select
Order> Back

from the image
drop-down menu

to send it to
the back.

Drag image
here, then
send it to
the back.

Drag image
here, then
send it to
the back.

Select how to mark correct
and incorrect answers.

Check this box to show a Solve
button during the activity.

Select the
number of
images to be
used in the
activity.

If you prefer not to use Flash-based activities, some activities are also available in a Notebook page format.
Flash activities are identified with a symbol, and Notebook pages are identified with a folded down top- --.,
right corner

Using a Flash activity or game in class
In class, you can lead the activity, or have a student come up to the interactive whiteboard to manipulate
the objects. Many of the activities include a Check button that will grade the activity, a Reset button that will
clear the activity, and a Solve button that displays the correct answers, enabling you to review the activity
with the entire class.

,'"""\

Tools
The Tools folder includes several Flash tools,
including random number, letter, card and
domino generators, image and keyword dice, a
voting tool, information buttons and word
generators, scrolling text bars and many others,
that you can use to add interactivity to your
lesson activities. The tools in the Examples
folder may help you generate some ideas.

. ~
p

Bailon pop Click and Dice - keyword Random card Random Letter
reveal - circle generator generator

When editing the tools, you can add text to a field by typing in a text field, or by dragging and dropping text
from the Notebook page into a text field.
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Pull tabs
Pull tabs are a useful tool found in the Lesson Activity Toolkit that are designed for hiding text or objects on
a Notebook page until you are ready to reveal them. Pull tabs can be used to detail activity instructions and
provide hints. They enable you to include a lot of information on a page, without cluttering it.

If you are not using the Lesson Activity Toolkit, you can create your own pull tab object using the Shapes
tool. Consider saving the pull tab in your My Content folder if you will use it often.

Creating pull tabs

1 Select a pull tab from the Graphics folder or create your own pull tab object
2 Drag the pull tab onto the work area

3 Add the pull tab text to the workspace using the text button

4 Select both the text object and the pull tab (press Ctrl and click on each one)
5 Select Grouping> Group. The two Objects will behave as one object.

6 Move the pull tab until the text is hidden on the edge of the page

7 During your lesson, use the pull tab to reveal the hidden text or image by pulling it toward the center
of the workspace

Conjugate the verb FA/RE Conjugate the verb FAIRE

Place the pull tab at the edge of the
workspace or object to hide the
attached text.

lais nous faisonsje

tu fa is VOU$ faites

iVelie fait
on

ils font
elles

Pull the pull tab to reveal the hidden text.

Help
The Help folder in the Lesson Activity Toolkit contains a link to www.education.smarttech.com/slat. where
you can find additional information and supporting materials for the Toolkit.
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Review: Building interactive lesson activities

1 How do you turn on Dual Page Display?

2 How do you attach a sound file to an object?

3 What are three object animation styles?

4 What are two ways to add text to a text field in an Adobe Flash activity, game or tool from the
Lesson Activity Toolkit?

5 How do you create a pull tab?
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Review: Building interactive lesson activities

1 How do you turn on Dual Page Display?

Press the Dual Page Display button on the toolbar or select View> Zoom> Dual Page Display.

2 How do you attach a sound file to an object?

Select the object that you would like to attach a sound file to and select Sound from its drop-down
menu. The Insert Sound dialog box appears. Press Browse to locate and select the sound file.
Select whether you'd like to launch the sound by clicking a corner icon or the object, and press OK.

3 What are three object animation types?

Fade in, fade out, flip around axis, fly in, fly out, shrink and grow, and spin

4 What are two ways to add text to a text field in an Adobe Flash activity, game or tool from the
Lesson Activity Toolkit?

You can add text by typing into the text fields, or by dragging and dropping text from the Notebook
page, word processing software or a webpage or other software program, into the text fields to
speed up activity creation.

5 How do you create a pull tab?

Select a pull tab from the Graphics folder and drag it onto the work area. Position it next to the
object you would like to group it with. Select both the object and the pull tab (press Ctrl and click on
each one), and select Grouping> Group. Move the pull tab until the text is hidden on the edge of
the page.
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ntegrating
rlch-medla into
esson activities

How can rich-media add value to my
lesson activities?
Rich-media files and tools appeal to a variety of learning styles, can add interactivity to the lesson and can
save you time.
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Integrating rich-media into lesson activities
There are many ways that you can take advantage of various types of rich-media when creating lesson
activities with Notebook collaborative learning software and a SMART Board interactive whiteboard.

Using the interactive whiteboard to complete research
on the Internet transforms research from an individual
activity to a whole class activity. SMART Technologies
even provides a list of websites that work well with a
SMART Board interactive whiteboard. This list can be
found at Education.smarttech.com > Educator
resources> Online classroom resources.

In addition to the Internet, there are several other ways
that media can be incorporated into a lesson activity.
You can record and replay actions with the Page
Recording feature in Notebook software or the SMART
Recorder. You can play, pause and write over video
using the SMART Video Player. You can also easily
import images and documents into Notebook software.

~
Technologies

North Arne

!l;l!Educator resciurces~

Education > Educator resources > Online classroom resources> El e rn e nta

Elementary

To narrow your search for web resources, use the categories (
search using the keyword field within a category.

_______ -'11 Search Resources I
Fi~er list by subject:

Art and Design: Cross-Curricular: English and Language !l.rts '

Food and Nutrttion ! Geograptw : History and Social Studies:
Mathematics : Music : Science

Page: 1 of 11

Resource

AAAMath.com
http://www .•••••••••math.com
Interactive arthmetic exercises and problems that contain a series of basi
math lessons, challenge games, teacher resources, homework help and r
more. Also available in Spanish.

Page Recorder
Using the Page Recorder, you can record any actions completed on the current Notebook page, including
writing with digital ink, adding and modifying Objects, and creating shapes. This recording is saved as a part
of the Notebook file and can be replayed at any time from that Notebook page. The Page Recorder enables
you to record an example of an activity or problem to replay when using the lesson activity in class. If
students are working independently at the interactive whiteboard, they can view and re-view instructions
and examples without seeking the help of the teacher.

To record actions on a Notebook page, complete the following steps:

1 Open the Properties tab
2 Press the Page Recording button
3 Press the Start Recording button

4 Complete any actions on the Notebook page that you would like to record

5 Press Stop Recording
A Page Recording toolbar appears at the bottom of the Notebook
page, which enables you to play and pause the recording from this [ II
Notebook page at any time. ~--------------------~J

Back Pause Play Record
You can also playa recording by pressing the Play button found
in the Page Recording section of the Properties tab.
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SMART Recorder
With SMART Recorder, you can make a video recording of your lesson, no matter which applications
you are using on the interactive whiteboard. If you have a microphone attached, you can also record your
voice. For example, this feature enables you to record sample math problems, incorporating the use of the
on-screen calculator or spreadsheet, then replay the file as a review for your students or for those who
missed the lesson. Recordings can be played using SMART Video Player or Windows Media® player
(available free from www.windowsmedia.com/download). You can also use the SMART Recorder to record
student work on the interactive whiteboard as a form of assessment.

SMART Recorder has a simple three-button interface that
enables you to control the recording process.

1 Press the Record button. By default, SMART Recorder
records the entire workspace, although you can modify
this setting.

2 Complete the actions you would like to record

3 Use the Pause and Record buttons throughout the recording as required
4 Press the Stop button to end the recording

5 You will be prompted to save the file. Select a location, name the file and press Save.
6 The Recording Complete dialog box appears, providing details of the recording, including file size and

recording time
7 If you would like to immediately view your recording, check Play Recording
8 Press OK

To record actions on the SMART Board interactive whiteboard,
complete the following steps:

(tMenu .••.) I 0:00:00

Record Pause Stop

Hiding the SMART Recorder
If you do not want the SMART Recorder to be visible
in the recording, or you don't want it to distract your
students, you can hide it in the notification area.

Record
P.:luse
Stop

Show

Configure Options ...
Help ...
About SrYlARTRecorder ...

Exit - ---.

To do this, press the Menu button and select Hide to
System Tray.

Click on the SMART Recorder icon to access a menu
providing you the same access to Record, Pause,
Stop and other features of Recorder. Select Show to
restore the SMART Recorder to full size.

The SMART Recorder icon in
the notification area.
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Setting the recording area
SMART Recorder has three options for the region of the
workspace that will be recorded. Selecting a smaller recording
area will reduce the file size and can eliminate distractions from
the recording, such as the task bar or any applications that are
open but not necessary for the lesson. Record Desktop (Default)

Record Area ...

Record Window ...
To specify the portion of your desktop that you would like to
record, press the arrow beside the Record button, and select
from the following three options:

• Record Desktop (Default) - Records the entire desktop

• Record Area ... - Prompts you to select the area of the screen you would like to record

• Record Window ... - Prompts you to choose a window that you would like to record
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SMART Recorder Menu
The SMART Recorder Menu button provides access to several options and settings that you can modify to
make SMART Recorder work best for you. To access these settings, select Options from the Recorder
Menu to launch the Options dialog box.

The Recording Quality tab
enables you to adjust the quality
levels of the sound and video
recorded, which also has an
impact on file size. For example,
you can change the number of
frames per second you record.
Movies recorded at a low frame
rate have a smaller file size than
those with a higher frame rate, but
the visual quality of the movie is
reduced.

The Video Format tab allows you
to choose a file format to save your
movie. The Windows Media Video
Files option creates a file that can
be viewed with Windows Media
player. The SMART Recorder
Video option creates a more
compressed file, resulting in a
smaller file size. This file can be
viewed only if SMART Board
software is installed on the
computer playing the video.

Recording Quality I Video Format If Target Files Jr Watermark 1
Higher sound quality will result in a larger file size.+

Sound Quality

The best way to improve the responsiveness of
your computer while recording is to reduce the
frame rate. The file size of the recording is also
reduced.

Video Quality IAutomatic Selection (Recommended) ~~

D Custom: 13.0 I (Frames Per Second)

.Bestore Defaults

OK ] [ Cancel 1 [ Help

Select the Target Files tab to change where your Recorder files are saved on your computer.

The Watermark tab enables you to add an image or text watermark to your recording, which would be
visible anytime the file is played. You could use this feature to include course or unit titles, the date of the
lesson or your school's logo. You can adjust the placement of the watermark on the recording, and the font
size, style and transparency of the watermark. You can also set a standard watermark to use each time you
create a recording or select Turn off watermark when SMART Recorder closes to revert to using no
watermark.
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SMART Video Player
With SMART Video Player, you can play video files located on your computer or an external device, such
as a camera, VCR, CD-ROM, DVD player or document reader.

Although other video players work on a SMART Board interactive whiteboard, when you are using SMART
Video Player, you can write over the video, whether it is moving or still. The transparency layer does not
appear over SMART Video Player when you pick up a pen tool from the pen tray. With other video players,
the transparency layer appears, and the video seems to be paused while you are writing. However, it
actually continues to play in the background and you miss portions of the video.

If you are writing notes you would like to save for later use, you can write over a frame of video and capture
your notes to Notebook software.

To launch SMART Video Player, click the SMART Board icon in the notification area and select Video
Player.

Total 0:00:00

"
"

~
Video Player

~ CJ~------------------------------------------------ ~ 0:0010:00
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SMART Video Player has an easy-to-use button interface that enables you to play and pause video, and
set your preferences for using digital ink with the SMART Video Player.

Button Use this tool to

- Show how much time is remaining in a movie.....-
Play or pause the movie'r-

~~

r-. Stop the movie and rewind it to the beginning. When using the pen
tool, this button changes to a Clear Screen button, enabling you to
remove any notes written over the video.

" - ~.~

Capture the current frame to Notebook software
~,

Return the mouse to cursor mode

, Use the cursor as a pen tool

·00 Change the color of the digital ink

- Change the line thickness of the digital ink--
ll@ Clear any notes written over the video

6:l View the video in full-screen mode

c;!J I Set the video to repeat continuously

Mute the sound

Adjust the volume

To view a video file, select File> Open and browse to a video file on your computer. When you have located
the file, click Open.

When you connect a video hardware device (such as a VCR, video camera or document camera) to your
computer system, SMART Video Player detects the device and adds it to the Hardware menu. To view
video from one of these devices, select it from the Hardware menu.

Play list
SMART Video Player has a play list feature that enables you to prepare and save a list of videos to use in
your lesson. To view the play list, select View> Show Playlist. To add a file to the play list, press the Play
List button and select Add. You can also reorder and remove files from the play list. To save the play list
for future use, press the Play List button and select Save.
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Video Player Settings
As there are many different potential uses for the SMART Video Player, there are several settings that you
can change to customize the way that the Video Player works and responds to your actions, including the
video playback speed, what happens when you pick up a pen tool and how long any notes you make are
displayed on the screen.

To access the Video Player Settings dialog box, select Settings> Video Player Settings.

Pause while writing
The default setting for Video Player is to pause whenever
you pick up a pen tool. With this setting, you can stop the
video, make notes and lead a discussion with your
students. When you are ready, you can put the pen down
to continue watching the video. Alternatively, you can
deselect the Pause when tool(s) lifted check box,
changing the settings so that the video continues to play
when you are using the pen tool. This action enables you
to highlight important points on the screen without
interrupting the flow of the lesson.

Fading out annotations
As the video plays, you might want your notes to
disappear without having to press the Clear Screen
button. To enable or disable the Fade out notes option,
complete the following steps:

1 Select or deselect the Fade out notes check box
2 Designate the amount of time (in seconds) that

should pass before the digital ink begins to fade and
how long it should take to clear the screen

3 Press OK

o Always on lop

o Pause when lool(s) lifted

o Fade out notes

Begin after ;~----'Isecond(s)

Continue for i Isecond(s)

o Remove loolbar in full screen mode

After ' Isecond(s)

o Remember last hardware source

r i)"iC"'~ [ Cancel 1 [ Help 1

Remembering the hardware source
If you frequently use SMART Video Player to display video from an external source, such as a DVD player
or electronic microscope, you can save on preparation time by checking the Remember last hardware
source option. SMART Video Playerwill automatically look for a video file on the last hardware source used.

Removing the toolbar in full-screen mode
To ensure that the video is visible for the entire class, you may want
to display the video in full-screen mode, using the entire interactive
whiteboard. When you select the full-screen view, a different toolbar
appears with buttons for playing and pausing the video, and for
capturing and clearing your writing. This toolbar also includes a
button for returning to normal view. ----------.~
Use the Remove toolbar in full-screen mode option to set how long this toolbar remains on screen. To
access the Video Player toolbar after it has disappeared, touch the interactive screen.
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Video Playback Speed
You can adjust the speed of video playback by
selecting Settings> Playback Speed. Tailor the
video playback to your class needs by selecting at
a slower or faster speed.

Help

Video Player Settings

Playback Speed ~r--------------------.
Very Slow (xQ,25)

Slow (xQ,5)

<I Normal (xi)
Fast (x2)

Very Fast (x4)

Ctrl + L

Ctrl + 0

Ctrl + F

Reverse Ctrl + R

Import images
In addition to using the many images and objects included in the Gallery, you can easily import your own
pictures into a Notebook file. To insert a picture from a file on your hard drive or network, complete the
following steps:

1 Select Insert> Picture From Scanner. The Insert
Scanned Picture dialog box opens.

2 Select a scanner from the list

3 Press the Scan button
4 Scan your picture and adjust it as needed, following the instructions provided by the scanner's

software

5 When the scan is complete, close the dialog box and return to Notebook software

1 Select Insert> Picture File. The Insert Picture File dialog
box opens.

2 Locate your picture file
3 Select Open to import the image into the current Notebook

page

You can also import printed material, such as an overhead
transparency sheet, if there is a scanner connected to your
computer.

Format Draw Help

Blank Page Ctrl+M

Picture File, , ,

Picture From Scanner, , ,

Flash File" ,

Flash Video File, , ,

Gallery Item File, , ,

Link" ,

Sound" ,

Table
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Importing a file with SMART Notebook Print Capture
SMART Notebook Print Capture is a printer driver installed with Notebook software that imports a file or
specified pages of a file into the Notebook file. Each page of the imported file appears as an object on its
own Notebook page, with its original formatting and page breaks preserved. This feature is different than
Capture to Notebook software, because it enables you to import full pages, page ranges and files, not just
the visible work area.

You can import Microsoft® Word software documents or any other type of document that you would normally
be able to print. This feature is particularly useful if you have existing electronic resources, but you would
like to take advantage of the interactivity that Notebook software enables. You can import worksheets and
documents that you would normally transfer to an overhead transparency. You can also use this feature to
save examples of students' work in one convenient Notebook file.

To import a file using print capture, complete the following steps:

1 In the source application, select File> Print. The Print dialog box opens.

2 Select SMART Notebook Print Capture from the list of printers

3 In the Print dialog box, select a page range

4 Press OK

NOTE: If Notebook software is already open, the pages from the source file are added to the Notebook
file after the current Notebook page. If Notebook software is not already open, it will launch.

Changing the properties of the SMART Notebook Print Capture driver
When you import a file with SMART Notebook Print Capture driver, each page appears as an image on its
own Notebook page. Just as with any printer driver, you can change the page orientation and additional print
properties.

To change the page orientation, do the following:

1 In the source application, select File> Print. The Print dialog box opens.

2 Select SMART Notebook Print Capture from the list of printers
3 Press the Properties button. The SMART Notebook Print Capture Properties dialog box opens.

4 Select Landscape orientation or Portrait orientation

5 Press OK
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Lesson evelopment
in Notebook software
How can Notebook software help me
to arrange the curriculum into
interesting and effective lessons?
Try integrating the tools and features covered in this workbook to build a lesson activity that you can use in
your classroom.
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Hands-on-practice
Create a lesson activity in Notebook software that you can use in your own classroom. The lesson activity
should contain the following items:

• Teachers' notes and lesson notes

• At least four pages

• Objects, backgrounds and multimedia objects from the Gallery

When developing the lesson activity, try to include at least two of the following skills we learned today:

Notebook
Print

Capture

SMART
Learning

Marketplace

Online
f------i~C la s s ro0m

resources

Structure
and

organization
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Delivering lessons
and leve ag-ng
interactive tools
How can I enhance my delivery of
lessons using Notebook software?
This course aims to enhance your delivery of interactive white board lessons through organizational
best practices, customization of the Notebook interface, delivery tips and hands-on practice leveraging
interactive tools.
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Organization and planning for a sophisticated delivery
The best way to prepare yourself for delivering your lessons on a SMART Board interactive whiteboard is
to create well-organized, well-designed Notebook software lessons.

An organized, well-designed lesson will enable the following:

• Smooth and effective navigation from page to page

• Clear and concise presentation of lesson content

• Increased flexibility to address student needs

• Clear expectations of what students or substitute teachers are to do during a lesson activity

• Lesson activities that perform as intended

• Minimal transition time between documents or activities, resulting in more effective classroom
management

Organization and planning notes
Please use the space provided below to note some features of Notebook software that will help you
organize and design your lesson for an effective delivery.
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Organization and planning notes, continued

Design your lesson to be delivered interactively
A SMART Board interactive whiteboard is different from a digital projector and screen in that it is designed
to be an interactive medium. A presentation graphics program such as Microsoft PowerPoint® software
can certainly be used on an interactive whiteboard, but showing pre-prepared slides in a linear format is
not the only or best option for lesson delivery on an interactive whiteboard. The interactivity of
whiteboards equipped with collaborative learning software allow and encourage teachers to be flexible,
nonlinear and spontaneous in their lesson delivery.

If lecture-style delivery is your preferred teaching method, there are still many advantages to using an
interactive whiteboard. However, to make maximum use of this tool, consider experimenting with
incorporating some interactivity into your lessons. Easy places to start are question-and-answer type
interactivity, diagram labeling and the use of interactive learning objects created in Flash software.
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Customizing Notebook software for effective lesson delivery
Teachers with a sophisticated delivery style don't distract their students from the lesson by searching for the
tools they need. Customize the Notebook interface to put all the tools you need for your unique delivery style
at your fingertips. This section outlines several of the customization options included in Notebook
collaborative learning software.

Customizing the Floating Tools toolbar
The Floating Tools toolbar provides instant access to interactive tools that
will help you deliver amazing lessons whether you are using Notebook
software or another application on the SMART Board interactive
whiteboard.

By default, the Floating Tools toolbar is anchored to the left-hand side of the
interactive whiteboard. If you are right-handed and find yourself needing to
access it frequently while writing and navigating, you may wish to drag this
toolbar to the right-hand side of the screen before beginning your lesson. "

Customize the properties of the tools that have side menus to minimize
Hide/Reveal delivery time spent setting them up to be useful for your lessons. Press the

.-- toolbar Customize button on the side menu. The Properties dialog box will appear
where you can change the settings for the tool.

.-- Move toolbar

You can save the new settings so they become the default for that tool by
clicking the Save Tool Properties button at the bottom of the dialog box
after you've set the parameters above.

Side menu Customize button

~
~' ~ ~,~~ -0 Propmi".

Properties dialog box

1

Floating Tools
toolbar
(default settings)

FI EHect.

Line Style

Color

lsave Tool Properties 1
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Customize your Floating Tools tool bar so that it contains all the tools you find yourself using frequently in
your lesson delivery.

Press the Customize button in the Floating Tools toolbar to choose from a variety of tool bar icons.
You can choose as many icons as you like to fully customize this toolbar with the tools you need
most often.

To add a button to the Floating Tools, drag and drop the icon onto the toolbar. To remove a button, ensure
the Customize button has been pressed, and drag the button off the Floating Tools tool bar.

Customize Floating Tools

AcId or remove items by dragging Ihem 10 or from the toolbar

~ ~ ~
Pen Creative Pan HighlightSf" ,"-Pen MagicPEln

o .! ~
Etase, Una S'- Undo Right4c11ek

esJ e :e
Keyboanl _k Wak:omaCenlar Instant Confar8oollg Magnifier

!!II c:::J § ~ Ii
Recoro.r Sa9anShaoe Spotlight PolnllH calculator

!Iiii ~J ~.:; €I
Screen CaoUJre Toolbar Alea Caplure Flit Screen Capture Fraelland Cap4llr& Prinl Screo&fl

~

To return the toolbar to its original configuration, press the Restore Defaults button.

When you are finished customizing the tool bar, press the Done button.
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Customizing the interface in Notebook software
Several options are available for customizing the interface of Notebook software so that it reflects your
delivery style and the needs of your classroom.

Customizing the toolbar
Arrange and customize the tool bar in Notebook software so that it best suits your delivery needs. Remove
tools that don't appeal to you or that you never use - this keeps your favorite tools more accessible. Place
the tools that you use most often near the side of the interactive whiteboard where you tend to stand when
delivering your lessons. It is a good idea to keep buttons with similar functions next to each other. For
example, in the default toolbar, all of the page navigation tools such as Next Page, Previous Page and Add
New Page are found in the same area of the toolbar.

Keep in mind that rearranging your toolbar regularly may confuse students and detract from the effective
delivery of your lessons. It is best to decide on an arrangement that suits your delivery needs and stick with
it.

To customize the toolbar, right-click on any button in the toolbar to launch the Customize Too/bar window.
Use this window to add or remove buttons from the toolbar. Drag a button from the tool bar to the Customize
Too/bar window to remove it from the toolbar. Drag a button from the Customize Too/bar window into the
tool bar to add it to the tool bar. When the Customize Too/bar is open, you can also rearrange the buttons
within the toolbar by dragging them to another location.

When you are finished customizing the toolbar, press Done.
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Sometimes, you may wish to limit
access to a toolbar during a lesson
so that it is not accidentally pressed.
In this scenario you might move the
toolbar to the least accessible position, at the top or bottom of the workspace.

Placement of the toolbar
By default, the toolbar in Notebook
software is located at the top of the
workspace. This is the most
accessible location for teachers and
older students to use the tools. If
young students or students with
mobility concerns are using the
SMART Board interactive
whiteboard, you may need to move
the tool bar to the bottom of the
workspace for easier reach. To move
the toolbar from the top to the bottom
of the workspace, or vice-versa,
press the double-sided arrow icon.

Notebook software training for SMART Board users level 2 learner workbook

I
Press the double-ended arrow icon to move the

toolbar to the opposite end of the workspace.

Placement of the side tabs
By default, the side tabs appear on the right-hand side of the workspace. These can be moved to the
opposite side of the workspace by pressing the double-sided arrow icon. To facilitate your lesson delivery,
it is best to place the side tabs on the side of the board where you tend to stand when delivering your
lessons. Left-handed presenters may find the side tabs more accessible on the left side of the workspace,
whereas right-handed presenters may find the side tabs more accessible on the right side of the workspace.

Check the Auto-hide check box to hide the side tabs from view and give yourself more workspace area.
However, leaving the Page Sorter tab visible while delivering a lesson puts the current page into the context
of the whole lesson. This appraoch helps some teachers organize their thoughts for a more effective
delivery.

Auto-hide
L

~Qo~==·~~~j_
check box

Double-ended

arrow icon

Page Sorter

tab
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Presentation tips for delivery on an interactive whiteboard
Body positioning
Face your students as much as possible while manipulating the SMART Board interactive whiteboard.

Keep your body position

When you need to reach something on the other
side of the interactive whiteboard,

When writing on the interactive whiteboard,

x

Touch tips
The most effective hand position for moving or
touching an object is

This is because

TIP: Remember to orient your SMART Board interactive whiteboard before every presentation to ensure
an accurate reading of your touch.
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Writing tips
Writing on an interactive whiteboard involves a slightly different technique than writing on a conventional
whiteboard or chalkboard. Like any skill, it takes practice. Note some tips to improve your SMART Board
interactive whiteboard annotations.

Manipulate the interactive whiteboard from the screen
One of the advantages of an interactive whiteboard is that teachers can instruct from the front of the room
- near the projected image - and navigate their digital lesson while facing their students. Teachers who
navigate their interactive whiteboard from the back of the room so that they can use a mouse are not
effectively using the technology.

Go ahead, mark up those documents
The interactive whiteboard is a great tool for highlighting and jotting notes on just about any type of
application or document. So go ahead, use the tools as intended and mark up that electronic document.
You can save these markings or delete them, it's up to you.
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Leveraging interactive tools
Use the space below to note key ideas for leveraging the interactive tools included in Notebook software.

Interactive tools Why/where would I use this tool in my lesson delivery?

Circle to erase

Creative Pen

Dual Page Display

Export

Full Screen view

Handwriting recognition

Highlighter

Insert Blank Page

Lesson Activity Toolkit tools

Magic Pen disappearing ink

Magic Pen zoom

Magic Pen Spotlight

My Content

Page Recording

Recognize Shape
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Ad-hoc lesson delivery
As a teacher, you know that it is sometimes desirable to deviate from planned lessons in order to manage
your classroom as effectively as possible.

The following are examples of spontaneous lesson creation that are often necessary:

• Enrichment tasks for students who finish early

• Transition activities for in-between time

• Impromptu explanations or demonstrations

• Extensions onto planned lessons

• Unplanned review of previous material

Notebook collaborative learning software has a number of tools to help you with these types of ad-hoc
lesson situations. This section outlines several ad-hoc lesson ideas to give you something to draw on when
you are faced with the need for a spontaneous lesson activity or lesson component.

Ad-hoc lesson ideas for Notebook software
The lesson ideas in this section have been selected based on the following characteristics of effective
ad-hoc lessons:

• Minimal transition and setup time

• Set up is interactive and purposeful

• Activity furthers desired student learning outcomes

Lesson Activity Toolkit

The Lesson Activity Toolkit is
included as an option when
installing Notebook software.

This toolkit adds content to the
Notebook software Gallery to aid
teachers in creating planned and ad-
hoc lesson activities. This section
will refer frequently to this valuable
component of Notebook software.

Lesson Activity-Toolkit 1.0
Activities
Games
Graphics
Help
Pages
Tools

Gallery Sampler
Use of the Lesson Activity Toolkit's Random domino generator for an impromptu
math activity
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Create some education games ahead of time
Make and collect a library of education games based on the topics you will be covering throughout the year.
The Lesson Activity Toolkit has an array of templates for popular games and activities created in Flash
software. Crossword puzzles, matching games, trivia, anagrams, word-guess games and more can be
easily created by inputting your own lesson content.

•
Edit button allows you _~~i====!!=!!!!!!===!==========~ Help button provides
to customize the . <11I- instructions on how to
d~~K~W~ ~~~~~
unique student activity
learning objectives

This software has many features to help
enhance your lesson delivery I

-.--1
Anagram game from the Lesson Activity Toolkit

Preparing these types of games requires a little bit of work ahead of time but, having a collection to draw
upon as a filler activity or enrichment task is invaluable when the need arises.

Relevant education games or interactive activities are also a powerful and fun way for any age group to
review material or start a lesson.

Use ready-to play strategy games
To ensure that the game-play in your classroom is relevant to
your specific student learning outcomes, the majority of the
education games included in the Lesson Activity Toolkit require
you to add your own content. However, several ready-to-play
strategy games are also included with the Toolkit to aid you with
impromptu classroom activities. Soduku, chess and checkers
are useful for teaching children strategy skills and, if used
judiciously, can be an effective enrichment task for small groups
of students.

Develop a collection of favorite websites
Develop a page in a separate Notebook software file that houses a collection of your favorite education
websites. Students can browse these websites on the SMART Board interactive whiteboard in small groups,
or as a class, when there is a spare moment.

NOTE: Use caution when allowing students to play games on the SMART Board interactive whiteboard
during free time. Games labeled educational mayor may not be teaching your students useful skills, and
using the SMART Board interactive whiteboard as a toy may demean its value as an education tool.
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Use random generator tools to setup ad-hoc lessons interactively
Tools such as the Random letter generator, Random number generator, Random card generator and
Random domino generator will help you set up ad-hoc lesson activities in a way that is intentional and
interactive. Use these tools, included in the Lesson Activity Toolkit, to provide students with planned or
unplanned extensions into number and word concepts .

..J No repeat

V AU L T

T
J Y

Y

:J Lowercase
..!6 Inject automatically

Ad-hoc word building activity using the Lesson Activity Toolkit's Random letter generator

Leverage the power of the Internet
The Internet is a powerful source of information that youth readily turn to for answers to their questions.
Planned or impromptu forays onto the Internet are easy to make during an interactive whiteboard lesson.
Using the Internet with students provides you with opportunities to teach them how to use it effectively as a
tool and sort valid from invalid information. The Internet is also a great way to link what you are teaching in
the classroom to real-world issues and dilemmas.

Pull up past lessons whenever review is needed
One of the nice things about regular teaching on an interactive whiteboard is the accessibility of past lesson
material. Keep lessons well organized so that you can transition smoothly to a review of a particular lesson
if you see that students are struggling with your current material.
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Use Notebook software as a course management tool
Use Notebook software as a tool to collect and organize relevant documents, websites, videos, images,
notes and activities. This sets you up with an easily accessible collection of information to draw on when
you need to spontaneously provide further explanation for a concept or extend your lesson in meaningful
ways.

The Attachments tab is one effective way to store
and organize lesson material. You can also collect
links on a separate page at the end of your lesson.

The My Content folder is another excellent method
of storing content, for images, Flash files, Notebook
pages and activities. My Content can be organized
into sub-folders to keep your material accessible for
when you need it. If you are on a school network,
you can also create a Team Content folder that
allows you to share lesson material with other
teachers on the same network.

IType search terms here

8 My Content
Grade 7a Science
Grade 7b Science
Grade 8 Science

Fluids
Magnetism ,.

Grade 9 Math
Template items

1111

Magnetism
4 items

0Pictures and Backgrounds (4)

electromagnet em wave
diagram diagram

loudspeaker magnetic field

Use of My Content to store and organize lesson material
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File Name

Attraction & Repulsion

Experiments • magnets

electricity lesson. not ...

Magnet game

Use of the Attachments tab to store lesson material

TIP: It is a good idea to back up your
My Contents folder. Click on the main My
Contents folder and select
Export as Collection File ... from the
drop-down menu.
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